Cookie機能
管理人様>
 長いこと、お世話になっております。
 「120195」と「220047」ですが、Cookieにチェックを付けていますが、機能していないようです。
 (いつも、投稿テーブルが真っ白)
 お手数をおかけしますが、確認をいただけませんでしょうか?

HIDE 2021/ 3/29(月) 20:05

確認しますのでしばらくお待ちください。

photobbs 2021/ 3/31(水) 13:28

確認しましたが、クッキーは正常に機能しているようです。
ご利用のブラウザのセキュリティ設定で、クッキーをブロックする設定になっているかもしれませんのでご確認ください。
よろしくお願いいたします。

photobbs 2021/ 3/31(水) 13:36

管理人様>
 本件、ご対応ありがとうございます。
 確認してみましたが、「クッキーをブロックする設定」の場所(意味)がわかりません。
 「セキュリティ」というメニューには入っているのですが…。
 クッキーの□は2ヶ所ありますが、そこにチェックで良いのでしょうか?

HIDE 2021/ 4/ 1(木) 20:56

返信が遅くなり申し訳ありません。
ブラウザの種類によって、クッキーの設定方法が違いますが、ご利用のパソコン(Mac、Windows)とブラウザの種類は何でしょうか。

photobbs 2021/ 4/ 5(月) 10:36

管理人様>
 対応、ありがとうございます。
 パソコンは「Windows」、ブラウザは「Edge」です。
 よろしくお願いします。

HIDE 2021/ 4/ 5(月) 12:23

管理人様>
 本件、その後の進捗をお知らせ願います。

HIDE 2021/ 4/11(日) 17:05

返信が遅くなり大変失礼いたしました。
Edgeのクッキーの設定は、
画面右上の「...」から「設定」をクリックして、「Cookieとサイトのアクセス許可」のところにあります。
一番上の「Cookieとサイトデータの管理と削除」をクリックし、「Cookie データの保存と読み取りをサイトに許可する (推奨)」が選択されていることをご確認ください。
よろしくお願いいたします。

photobbs 2021/ 4/13(火) 15:01

管理人様>
 本件、ありがとうございます。
 設定とは、Edge内の設定のことだったのですね。
 それであれば、以前より「推奨」になっています。

 念のため、投稿してくれた方に状況を確認したのですが、やはり「cookie」にチェックをしていても「まっさら」になってしまうそうです。
 個人PCの問題ではなさそうですので、再度、調査をお願いします。

HIDE 2021/ 4/18(日) 19:34

返信が遅くなり大変失礼いたしました。
再度確認しますので、もうしばらくお待ちください。
よろしくお願いいたします。

photobbs 2021/ 4/28(水) 12:05

MacとWindowsの複数のブラウザ(Edge、Chrome、safari,Firefox)で確認しましたが、クッキーが保存されない状態が再現されません。
ブラウザの設定画面で、photobb.netのクッキーを削除して試していただけますでしょうか。
お手数をおかけしますが、よろしくお願いいたします。

photobbs 2021/ 4/30(金) 15:16

管理人様>
 本件、ありがとうございました。
 こちらで再調査した結果、ホームページにフレームを付けているのですが、その状態でBBSを表示させると「cookie」が機能せず、BBS単独で表示させると「cookie」が正常作動することがわかりました。
 ホームページの構成は、ここ10年以上変更しておらず、「cookie」が正常作動している時もありました。
 何か、フレームに対するアドバイスがありましたら、教えてください。
 よろしくお願いします。

HIDE 2021/ 4/30(金) 16:37

遅くなって申し訳ありません。
フレーム内でのcookieは、ブラウザのセキュリティ機能によって機能しなくなっているようです。フレーム内でも機能する設定を追加しましたが、いかがでしょうか。

photobbs 2021/ 5/14(金) 15:09

管理人様>
 ご対応ありがとうございました。
 修正いただいたようですが、「Cookie」は効かないようです。
 (Admin内で、どこかの設定を変更するのではないですよね?)

 もうスレも長くなってきて、他の方々にもご迷惑がかかってしまいますので、このあたりで終わりとさせていただきます。
 引き続き、フレーム時の「Cookie」対応について、検討いただけましたら幸いです。

 ありがとうございました。

HIDE 2021/ 5/17(月) 19:29

cookieの追加設定は、設定画面ではなく、クッキー情報を送る際のプログラム内のことでした。
セキュリティに関係するので詳しくは書けませんが、クッキー情報にSameSite=None;を追加しています。その際に必要なSecureオプションが抜けていたので追加してみました。これで反映されないと、現状では対応の方法はないと思います。
今後も、情報が見つかれば対処しますので、よろしくお願いいたします。

photobbs 2021/5/21(金) 09:45


管理人様>
 ありがとうございました。
 画像の通り、反映されませんでした。

 今後の対応に期待しています。

HIDE 2021/ 5/21(金) 22:27

ページのソースを確認しましたが、掲示板のリンクを、http://からhttps://に変更して試してみてください。


photobbs 2021/5/22(土) 09:59

管理人様>
 対応、ありがとうございます。
 書き換えましたが、残念ながら「cookie」は効きませんでした。

HIDE 2021/ 5/24(月) 20:17

親フレームのページもSSL対応でないとクッキーは効かないかもしれません。
よろしくお願いいたします。


photobbs 2021/ 5/27(木) 16:16

管理人様>
 了解しました。
 ありがとうございました。

HIDE 2021/ 5/30(日) 08:29
Comment
お名前
内 容
文字色
画 像 5MB B/W 1:1
編集キー